This post is at: ForumGeneral Questions
12 posts / 0 new
Last post
mattdarnell
mattdarnell's picture
Joined: 2007/10/25
Points: 10

8.3.1.2 Multi
1.4.1 Connect
Calling using callback

I am trying to place a call from the Android version of Connect and receive the following error in the console:

[2018-02-02 21:19:56] ERROR[1683]: chan_sip.c:17208 register_verify: 'UDP' is not a valid transport for '122-comtel'. we only use 'WS'! ending call.

[2018-02-02 21:19:56] NOTICE[1683]: chan_sip.c:28508 handle_request_register: Registration from '"Matt Darnell" ' failed for '141.239.175.83:5060' - Device not configured to use this transport type

Is there a place to enable wss?

-Matt

volodya
volodya's picture
Joined: 2017/01/05
Points: 70

Hello Matt,

Please check to be sure that there is no SIP phone trying to connect to the system. Also, do you see little green status circle next to your profile icon in the top left corner?

mattdarnell
mattdarnell's picture
Joined: 2007/10/25
Points: 10

Interesting, the SIP phone attempting to register could be causing the error.

Our main use case is people have desk phones and only use the app when they are out of the office. I don't see how we can get users to unplug their desk phone when they want to get calls on the app.

I will test tonight and let you know.

volodya
volodya's picture
Joined: 2017/01/05
Points: 70

Users should not be unplugging their desk phones. Log messages that you sent are not related to the problem with dialing out. Please check if Connect is registered in Asterisk by running "sip show peers" command.

mattdarnell
mattdarnell's picture
Joined: 2007/10/25
Points: 10

Here is a video of the issue. If I am on SIP phone mode, it will dial my phone - but not when I am in app mode.

The Asteirsk console is the background, nothing happens when I dial in app mode.

https://www.youtube.com/watch?v=RAUYLolDBHg

mattdarnell
mattdarnell's picture
Joined: 2007/10/25
Points: 10

The phone is a Note 8

mattdarnell
mattdarnell's picture
Joined: 2007/10/25
Points: 10

Is this feature supposed to work?

eeman
eeman's picture
Joined: 2007/11/06
Points: 200

after you switch modes to 'use application' do a 'sip show peer XXXX' where XXXX is your exten-tenant to confirm it is showing available. Also how did you make this recording? Knowing this would be very useful for some instructional videos.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

mattdarnell
mattdarnell's picture
Joined: 2007/10/25
Points: 10

I will try that, thanks!

mattdarnell
mattdarnell's picture
Joined: 2007/10/25
Points: 10

Erik,

I used team viewer to be able to view the phone on my screen. On top of that I used OBS Studio to record the screen and audio - https://obsproject.com/

-Matt

thirdlane
thirdlane's picture
Joined: 2007/02/07
Points: 320

Hi Matt,

Are you still experiencing this problem?

Alex Epshteyn
Third Lane Technologies
Multi Tenant Asterisk PBX

mattdarnell
mattdarnell's picture
Joined: 2007/10/25
Points: 10

Yes we are.