5 posts / 0 new
Last post
voipempire
voipempire's picture
Joined: 2009/07/09
Points: 0

I have an issue.

I am trying to set these up however it is removing the - when it
registers.

It should be 1103-jar but it submits 1103jar

Here is the trace:
chan_sip.c:18529 handle_request_register: Registration from '"JAR" ' failed for '96.248.46.9' - No matching peer found

eeman
eeman's picture
Joined: 2007/11/06
Points: 260

some devices refuse to accept a dash in the username (cisco iad's work like that). The SIP RFC claims that acceptable characters include a dash but some devices just dont comply. Sometimes just updating firmware will resolve the issue. When the polycom/spectralink wireless base station first came out it didnt accept a dash but they already had a firmware release out right around the time they started shipping.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

voipempire
voipempire's picture
Joined: 2009/07/09
Points: 0

I do have the latest firmware. I did contact the company and am waiting for a call back.

Thanks

voipempire
voipempire's picture
Joined: 2009/07/09
Points: 0

Is there a good SIP proxy that can translate the registration that will run on windows. I have a spare windows server box with a public IP and would like to use it for the 3 phones I have.

Most of the ones I found are all linux based. I can run it on a linux box but I would have to set one up just for this.

eeman
eeman's picture
Joined: 2007/11/06
Points: 260

the only 'proxy' that will 'translate' your registration that i am aware of is Edgemarc devices. Its technically not a proxy but your end result will be what you are looking for. Its a full blown firewall/network device.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com