16 posts / 0 new
Last post
shall@snapsinc.com
shall@snapsinc.com's picture
Joined: 2008/10/15
Points: 0

How do I set the timezone in the Voicemail menu for users? Currently I have it displaying as a UTC date.

shall@snapsinc.com
shall@snapsinc.com's picture
Joined: 2008/10/15
Points: 0

Is there an easy way to export the call detail records to Excel or to a CSV file?

eeman
eeman's picture
Joined: 2007/11/06
Points: 290

/var/log/asterisk/cdr-csv/Master.csv

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

phoetger
phoetger's picture
Joined: 2010/11/09
Points: 0

Have you found the setting yet to change the UTC date to the correct timezone on the voicemail?

The recorded calls and the call history shows up as our time zone, but voicemail displays in UTC.

Thanks

eeman
eeman's picture
Joined: 2007/11/06
Points: 290

what does your voicemail.conf file say?

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

phoetger
phoetger's picture
Joined: 2010/11/09
Points: 0

tz = eastern

eeman
eeman's picture
Joined: 2007/11/06
Points: 290

so does your msg000.txt files show the correct times inside?

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

sabrejeremy
sabrejeremy's picture
Joined: 2009/01/19
Points: 0

Erik

Is there any way to make time zone specific per tenant?

I have customers in multiple time zones which makes things a little difficult for the user specifiicly in scheduling as well as all other time stamps.

Thanks for your help in advance.

Virtel Voice LLC

eeman
eeman's picture
Joined: 2007/11/06
Points: 290

the voicemail.conf file only accepts two timezone settings..

1. global
2. per mailbox

there is no tz setting for a context.. so when creating an extension you will have to use the tz= additional option (each tz has to also be defined in voicemail.conf as well before declaring)

if you want to make things easier on yourself you could stick to only GMT time stamps and tell the customers that because you are multi-timezone provider that in the interest of fairness you set the system to GMT time. (file date/time stamps are always set to system time).

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

IVSCOMM
IVSCOMM's picture
Joined: 2008/03/18
Points: 0

I am probably doing it wrong but here is what I did.

I went into the voicemail.conf file and uncommented the tz=eastern. didn't work, still displays UTC time in VM
added it to the voicemail options in the extension still did not work.

Help

My vm's still display in UTC time and I want eastern.

Shawn

Shawn Wright
IVSComm

voipmigration
voipmigration's picture
Joined: 2011/11/22
Points: 0

Thanks for sharing . I have also search to resolve this issue and found a many speculations . I think you can get help from here .
http://astbook.asteriskdocs.org/en/2nd_Edition/asterisk-book-html-chunk/...

IVSCOMM
IVSCOMM's picture
Joined: 2008/03/18
Points: 0

I have tz=eastern in the options of the voicemail and it still shows UTC time. How do I change it?

Shawn Wright
IVSComm

IVSCOMM
IVSCOMM's picture
Joined: 2008/03/18
Points: 0

The date and time stamp are correct in the body of the email message sent to me. it is only incorrect in the date and time stamp showed on the portal.

Shawn Wright
IVSComm

eeman
eeman's picture
Joined: 2007/11/06
Points: 290

because that time is the time of the file, not of the envelope. what you get emailed is what is in the body of the msg000.txt file. What you see when you do an ls of the directory is the timestamp of the file in unix time and translated to your time based on /etc/localtime

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

IVSCOMM
IVSCOMM's picture
Joined: 2008/03/18
Points: 0

Ok So is there a way to show the EST time and not the Unix time of the file. Customers don't want to see Unix time.

Shawn Wright
IVSComm

seereddy
seereddy's picture
Joined: 2017/09/07
Points: 0

Hi, How to change the time zone for a tenant ?