48 posts / 0 new
Last post
cbbs70a
cbbs70a's picture
Joined: 2008/04/10
Points: 0

Hello;
I setup a conference room as a test, and was able to access it using the script tl-dialconference-prompted, no problem. However, when I used the Conference Manager, both as admin and a user (I made sure I was the owner of the room) I was not able to see any users in it. What am I missing here? Any insight at all would be appreciated.
Thanks
FSD

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

I recently discovered this bug and reported it to Alex. I could not get the conference manager to work if the AMI password for user 'manager' was set to anything besides the default 'insecure' password. This is being looked into.

A couple of other things to check...

manager.conf has deny and allow access rules. You need to make sure that the subnet your PC is connecting from has access. Additionally you need to make sure you arent blocking AMI access at the firewall level anywhere.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

thirdlane
thirdlane's picture
Joined: 2007/02/07
Points: 510

The bug has been fixed (thanks to Erik and George for reporting) - will be uploading a new build today.

Alex Epshteyn
Third Lane Technologies
Multi Tenant Asterisk PBX

cbbs70a
cbbs70a's picture
Joined: 2008/04/10
Points: 0

Erik;

Thanks for the tips, but unfortunately, the password is correct, the access rules are correct, and I am not blocking AMI. Yet I still cannot see users in the conference room.

Regards;

FSD

thirdlane
thirdlane's picture
Joined: 2007/02/07
Points: 510

Please try updating to the latest version and let us know if the problem still there.

Alex Epshteyn
Third Lane Technologies
Multi Tenant Asterisk PBX

cbbs70a
cbbs70a's picture
Joined: 2008/04/10
Points: 0

Alex;

I updated to the latest version and tried it again. I entered the conference and looked at the output of the Asterisk console for error messages. I then logged into the user portal as the conference owner. I could not see anything in the conference manager, but I did see this in the Asterisk console:

== Parsing '/etc/asterisk/manager.conf': Found

== Manager 'manager' logged on from 127.0.0.1

== Manager 'manager' logged off from 127.0.0.1

== Connect attempt from '192.168.2.3' unable to authenticate

192.168.2.3 is my workstation. However, I have this in my manager.conf

[manager]

secret=insecure

deny=0.0.0.0/0.0.0.0

permit=127.0.0.1/255.255.255.0

permit=192.168.1.0/255.255.255.0

permit=192.168.2.0/255.255.255.0

read=system,call,log,verbose,command,agent,user

write=system,call,log,verbose,command,agent,user

Why would I be unable to authenticate? Very strange.

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

thats a normal message... look for a subsequent message saying manager login from your IP. Otherwise you will get a warning message.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

cbbs70a
cbbs70a's picture
Joined: 2008/04/10
Points: 0

Erik;

After I go into the conference manager, I get the last line above, == Connect attempt from '192.168.2.3' unable to authenticate. There is nothing else after that.

FSD

thirdlane
thirdlane's picture
Joined: 2007/02/07
Points: 510

Try specifying permit=192.168.2.3/255.255.255.0

(I know it does not make sense that specifying a network would not work, but any way - try the host).

Alex Epshteyn
Third Lane Technologies
Multi Tenant Asterisk PBX

cbbs70a
cbbs70a's picture
Joined: 2008/04/10
Points: 0

Alex;

I tried that also, but no joy. I am open to suggestions. Where else should I be looking?

Thanks

FSD

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

is it just conference manager that isnt working or is Tools --> Manager Interface also failing to authenticate?

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

cbbs70a
cbbs70a's picture
Joined: 2008/04/10
Points: 0

Hmm, good point. From my workstation I can telnet to the manager port (5038) and authenticate and see responses. However, from the Tools -> manager interface, (same workstation) I'm not seeing anything.

FSD

thirdlane
thirdlane's picture
Joined: 2007/02/07
Points: 510

Strange. You are running 6.0.1.59? If you allow me to connect to your box I could take a look - we will also have to add my address to the manager :).

Alex Epshteyn
Third Lane Technologies
Multi Tenant Asterisk PBX

cbbs70a
cbbs70a's picture
Joined: 2008/04/10
Points: 0

Alex;

I really appreciate you going the extra mile here, I really do. If you contact me offline at frank (at) digennaro (dot) com I can make the machine reachable from the outside.

Thanks much;

FSD

kyriakos
kyriakos's picture
Joined: 2008/01/03
Points: 0

Hi guys,

Im facing the same issue on 6.0.1.63. Did you manage to solve this?

Kyriakos

Otenet Telecom

kyriakos
kyriakos's picture
Joined: 2008/01/03
Points: 0

ok found the post regarding the adobe policy thingy..

justdave
justdave's picture
Joined: 2008/07/17
Points: 0

(Repeating basics here for those that didn't find the other thread) The connection attempt that fails to authenticate is probably Flash asking if it's allowed to connect. When it doesn't get the policy response it's wanting, it stops trying. To fix, you have to set up the flashpolicyd on port 841.

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

How can I check if this policy is setup correctly.

I am having the same problem where I am not able to see conferance members as they join the conferance.

I have done the Manager.conf changes and can get the Manager Interface to work correctly on the Tools menue. Alex has checked the flash policy options have been done on the MT server.

The Diagnostics Window on the web page flash control show the following.
INFO : ConferenceManager v1.1.6
INFO : ConferenceManager.init
A=t
SA=t
SV=t
EV=t
MP3=t
AE=t
VE=t
ACC=t
PR=t
SP=f
SB=f
DEB=f
V=WIN 10,0,45,2
M=Adobe Windows
R=1280x1024
DP=72
COL=color
AR=1.0
OS=Windows Vista
ARCH=x86
L=en
IME=t
PR32=t
PR64=f
PT=ActiveX
AVD=f
LFD=f
WD=f
TLS=t
ML=5.1
INFO : ConferenceManager.init
(Object)#0
conf = "3Support"
inf = "5A518D17975E84A77C1EBE5C953F6286455F73B2C24F1D63B736DAF5D27BB9A4909A7970"
INFO : ConferenceManager.init
HASH = manager:********:206.123.127.17:5038

Still no joy. I believe this is working for many but I am still missing something.
I don't what the next thing to check would be.
Any pointers.

Asterisk version 6.1.5 and PBX Manager version 6.0.1.78

Denis Camp

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

well if the manager interface screen actually prints out data continously to the screen then your policy is working fine.

I have no knowledge whether or not the conference manager tool works with 1.6.1.x branch or not. You see, they(digium) keep re-writing the whole API every branch release and its hard to keep up with a moving target.

try it will 1.6.0.15 and see if you experience the same issue.

does the dynamic agent screen in the userportal work for you? You'd need to add someone as a dynamic member of a queue and log into that station's userportal.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

thirdlane
thirdlane's picture
Joined: 2007/02/07
Points: 510

Denis,

Do you get Tools -> Manager interface authenticated?

Could you please post your manager.conf data?

Alex Epshteyn
Third Lane Technologies
Multi Tenant Asterisk PBX

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Yes, Manager Interface tool did authenticate.

-----------------------
Asterisk 1.1
-----------------------
Result: Login
Response: Success
Message: Authentication accepted
ActionID: 280D5EF4-4AAB-FA33-DB25-679282D00511
-----------------------
Event: StatusComplete
Items: 0
ActionID: 3ABC1E7B-D9EA-2878-38E5-67928440A337
-----------------------

Below is my manager.conf

[general]
enabled=yes
port=5038
bindaddr=0.0.0.0
writetimeout=200

[internal]
secret=insecure
;deny=0.0.0.0/0.0.0.0
permit=127.0.0.1/255.255.255.0
read=system,call,log,verbose,command,agent,user
write=system,call,log,verbose,command,agent,user

[manager]
writetimeout=200
secret=insecure
;deny=0.0.0.0/0.0.0.0
permit=127.0.0.1/255.255.255.0
permit=192.168.0.0/255.255.0.0 ; RFC 1918 addresses
permit=10.0.0.0/255.0.0.0 ; Also RFC1918
permit=172.16.0.0/12 ; Another RFC1918 with CIDR notation
permit=169.254.0.0/255.255.0.0 ; Zero conf local network
permit=10.4.13.0/255.255.255.0 ; Stuart's home network
permit=76.184.0.0/14 ; RoadRunner HoldCo LLC

read = system,call,log,verbose,agent,user,config,dtmf,reporting,cdr,dialplan
write = system,call,agent,user,config,command,reporting,originate

Denis Camp

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

dude, do you realize you can make free phonecalls off this config? you should never comment out the deny field. Without the deny those permit are useless, you are allowing anyone in. First you deny everyone then you specify who is allowed in, similar to setting up codecs on a channel.

Leaving the password set to the default leaves scripts to search for open AMI sockets with default password attempts.. once authenticated its as easy as

Action: Originate
Channel: SIP/myname@1.2.3.4
Context: from-inside-yourtenant
Callerid: some number to spoof

and before you suggest I wouldnt know the context consider

Action: Showdialplan

will list all your contexts

I could run credit card scams and place free calls off your PBX all day long.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Yes, Thanks for the heads up.

I did this for testing to make sure nothing was blocking my access for manager.
I commented the deny for a quick test. It is now back the way it was. Don't believe this was the problem anyway as the Mangager Interface is working fine and the Agent portal on the user portal is also working.

The system is not in production but better to be safe than sorry.

Denis

Denis Camp

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

good to hear, I'm very paranoid about the fallout of an open AMI port. I don't think people realize just how powerful that connection can be. It's also why I believe that these flash tools should make use of some middleman to proxy their communication through so that its impossible to run a port scan for open AMI connections and then sniff/bruteforce the password. The communication of AMI is plain text so its even possible to sniff over wireless or anywhere else one of these clients happen to be located and just collect the credentials.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Any further pointers from the forum on the issue with Conferance Manager not showing calls in Flash Pannel? I am out of ideas on my side.

I am not able to get calls to show up in conferance room using Conferance Manager.

The conferance bridge is working with a few minor issues which may be related the the asterisk version I am now running. I am running asterisk 1.6.1.5 and MT pbx manager of 6.0.1.79. The minor issues are no MOH for first caller and I don't hear the beep tone when a user comes into the conferance. Don't think this is related to the problem I have with Conferance Manager GUI.

All the controls at the bottom of the manager show up fine and I don't get any errors on GUI or looking at Diagnostic window on

Denis Camp

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

well i'd definitely want you to test with asterisk 1.6.0.15 and see if there is a difference.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

thirdlane
thirdlane's picture
Joined: 2007/02/07
Points: 510

Which version of Asterisk and PBX Manager? If you can please update to the latest version.

I know of a backward incompatible change in 1.6.X.X (don't remember specific branch/release) that broke Conference Manager - and required us to make a change to make it work with both 1.4 and 1.6

Alex Epshteyn
Third Lane Technologies
Multi Tenant Asterisk PBX

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

I will have to test that load on my lab system. I have not been able to get conferance manager to work on my lab system as well so I may have the same issue on both systems. Probably something I have not configured correctly. On my lab system everything is local so I don't have external firewalls to contend with and it is a bit easier to snif my network traffic.

Digium wanted us at 1.6.1.5 for the FAX to Asterisk which we are also testing.

I will have to check to see if 1.6.0.15 is ok for the FAX for Asterisk before going there.

Denis

Denis Camp

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

1.6.0.15 is the same FFA improvements as 1.6.1.5 FYI

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

1.6.0.14 and 1.6.1.5 came out the same day and have the same FFA changes. Thats why you'll see those version forks in the download section.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Just upgraded my system to 1.0.6.79 PBX Manager. Same problem. Also tested with 1.0.6.79.

Denis Camp

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Sorry... typo.
Also had same problem on 6.0.1.78

Denis Camp

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Thaks Erik,
I will try 1.6.0.15 tonight and see what happens.
This is what i get for living on the bleeding edge. Thanks for your patients.

Denis

Denis Camp

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

digium never did fix chan_dahdi for 1.6.1.x the entire time its been in release, and its probably broken in 1.6.2.x as well. Calling a channel already on a call results in one-way audio 100% of the time and occasional crashing of asterisk.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Upgraded to Asterisk 1.6.0.15.

No change on original problem with Conferance Manager :(

The upgrade did fix.... at least it now answeres.... my Fax to Asterisk calls:)

I will check some other features to make sure I didn't loose some critical features like MT Call Parking, etc. Thanks for your pointers so far.

If you have any further thoughts on Conferance Manager ... I am at your command.

Denis

Denis Camp

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

so far i am very unimpressed with 1.6.1.x .. someone else mentioned that the FAXOPT function values are not being properly set in 1.6.1.x with the FFA modules.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

its starting to seem as if the 1.6.1 branch is the windows Vista of the asterisk branch structure.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

We have another new customer on MT Thirdlane that is having the same issue reported in this tread about Conference Manager GUI not working. Is this working for others on 1.6.X.X? Does this problem have anything to do with asterisk versions? I have tried several browser types, windows versions, have not found the magic formula.

I have tried and still have not found the solution to my problem. I obviously don't know enough about how this all works, so I am still looking for some additional things I can look at or try in order to fix this problem. Still a bit of a novice, but willing to learn.

We are a distributer so I am not sure if I need to send the new MT customers to the TL forum for help on this or just work the Conference Manager GUI issues with these new customers myself, with the forums help, of course. I think if I can get mine working and understand more about why it isn’t working, I will be able to help other new customers get this working if they have problems.

Thanks for the help.
Denis

Denis Camp

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

I just tested it in our demo room thats running a 1.6.0.x branch and the conference manager works just fine so its confirmed to work with 1.4.x and 1.6.0.x

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Yes, Thanks for checking.

I did try 1.6.0.5 and 1.6.0.15 as you suggested and still had the problem.

I suspect I have something else wrong with my setup on several systems that I am currently working with. Maybe just my bad, but I am ignorant as to where I am ignorant.

What can I be looking for. What kind of IP packet would be sent from TL server when a caller joins the conferance, so I can verify that TL server is sending what it should send when it gets a new person in the conference bridge. I am not clear on what should be sent on what port, and what the browser flash control should see when it gets a new conferance member joined message so it will display the icon in the flash. I am guessing that is how it works. This is typical for me... things just don't work until I fully understand exactly what is supposed to happen. I am thinking they are just manager IP messages but I have lots to learn about that as well.

I seem to be getting other manager options to work like Manager Interface and user agent poral, which I am also guessing is using the same technology.

I hope I am not wasting the fourms time with a simple step I missed but it seems to be tripping up several of our new MT customers who have tried it lately. I can't really say I know everyones version, but the ones I know about use 1.6.0.5 from current ISO. I am the only fool willing to try other Asterisk versions in attempts to get other features working. As I mentioned, I had trouble getting the MT Parking to work until I tried 1.6.1.12 and I saw another post from the forum that said the new parking feature was never in the 1.6.0 branch. So I think I need to stay on 1.6.1.xx branch and struggle on in trying to understand what is really going wrong with Conferance Manager GUI . Again, I believe the problem is happening on both versions, and on several systems I have attempted, so it very well may be just something I am doing wrong. Your tests indicate it should work on 1.6.0 so I must have something wrong not related to Asterisk at this point. I don't have any customers on version 1.4 that are complaining about this problem, but many don't even use the user portal or know what Conferance Manager is for.

Thanks again for your help in this forum.

Denis Camp

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

I am getting a little closer to my solution. At least I have a better understanding of how it works. I am able to see the AMI messages at my PC running a browser, e8 or mozilla, with the conferance manager GUI page up. Using Wireshark, I can see the AMI messages when someone joins the Meetme conferance but nothing is displayed in the Flash control. When I click on the conferance controls at the bottom of the conferance manager I can see AMI messages sent to the TL Server.

How do the manager AMI packets I get from TL/Asterisk, get passed to the Flash control in browser so flash can display the user icon in the manager control. I think this majic is what is broken for me.

I was hoping I could see the manager AMI messages in the diagnostics window on the manager flash control but I dont see any data in window other than the initial message I posted a few days ago. This may also be an indication of the problem. Perhaps the Flash control is not linked to the AMI messages I clearly see on the PC I am running wireshark on. I am having this problem with different PCs, different browsers, and on different system with different versions of asterisk. My nose tells me I am dealing with a windows/flash/browser/ issue.

Maybe the AMI messages I am getting should have a flag or value that will only allow the data to be presented to a specific Flash control and that isn't matching up. How can I verify this. I am just clicking on the Manage Conference link on the Conference Room page logged in as root. Is this where I went wrong? Do I need to manage the conference from the user portal?

Can someone give me an indication if I am getting "hotter or colder" in my persute to understand and ultimitly fix my conferance manager problem.

Thanks team.

Denis Camp

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

you're using a 1.6.0.x branch still right? dont go back to 1.6.1.x until we get a 3rd party confirmation that it works. Thats diagnostic problem solving 101 =)

as far as the flash application it see's all the messages and parses their output.. its similar to the way old dialup scripts worked.. its listening for structure, and performing an action based the message.

the original problem... going from 1.4.x to 1.6.0.x resulted in messages formatted differently and thus the flash did not recognize the messages. This was fixed a few versions ago. This problem can re-appear at _every_ branch release, anytime the developer community decides to go re-invite the wheel. This happens _all_ the time and thats why I keep insisting you stick with 1.6.0.x until we get _that_ version working, and then we try 1.6.1 or 1.6.2 etc. The chance something changed since the last time the flash app was modified is extremely high.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Understood.

Am I correct about 1.6.0 branch does not support the new MT Parking option? I think I also notice some bizzar BLF indicators on my Aastra phones where lamps would come on look like users were off-hook if their phone was not registered.

I can test this further using my lab MT 1.6.0.X and load the version you tested with and at least get this to work. If this doesn't work for me I will try 1.4 and test again.

Is there a possibility my Browser Flash control is cashed in memory on my PC and set to look at 1.4 messages and therefore missing the messages 1.6.X is sending? My conferance manager control says 1.1.6 at the bottom of the control. Is this always updated when the TL Server presents a new conference manager window with the flash control?

I will update you on my progress... if any ... on testing with my lab system on 1.6.0.15 or would you prefer current?

Denis

Thanks for your pointers Erik.

Denis Camp

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Ok, Just loaded 1.6.0.current. (astrisk 1.6.0.26).

Created a new conferance room, feature code pointed to conference room, called and joined conference room. no problem here so far with normal meetme operation.

The conference manager is giving me the same problem where conference members are not showing in Flash control. manager interface is authenticated and showing activity on TL information. Agent portal works also.

The plot thickens.

Denis

Denis Camp

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

i dont know about flash caching.. i know in java thats a problem which is why I always turn off caching and flush the cache out. As a developer caching old versions can really mess with your head.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

eeman
eeman's picture
Joined: 2007/11/06
Points: 280

i think i just realized your problem, why is your conference room number '3Support' .. a conference room number HAS to be a NUMBER. Change your conference room to a # and monitor that conference.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

You are correct Erik

Why did I name the conference that way. No reason. Didn't know it made a difference. It did because now it works fine if I create the conference with just numeric.

My bad again.

Thanks to Alex who also pointed it out to me 1hr. ago.

Live a learn.

Denis Camp

Denis Campq
Denis Campq's picture
Joined: 2007/12/15
Points: 0

Thanks for all the help from the forum.

Conference Manager works fine on both 1.6.0 and 1.6.1 asterisk branches, as long as you use only numeric in conference name. I made the mistake to create it like a queue or trunk with a generic name like sales or support. On the positive side, I learned a lot about how this actually works.

A good thing for TL to do is check for non numeric chars in the conference room number field before saving and tell the idiot they cant use non-numeric characters. Also add “numeric only” in note text below field.

Obviously not idiot proof. As I demonstrated. If it can be done wrong... it will.

Denis

Denis Camp