4 posts / 0 new
Last post
telligent
telligent's picture
Joined: 2017/11/16
Points: 0

We're on the Multi Tenant platform and have a few remote GXW4224 giving us trouble. Extensions will randomly lose registration until the ATA is rebooted. This usually only happens to 1 or 2 of the 24 extensions on a single ATA. Running a sip debug show us the following for the offending extensions:

Correct auth, but based on stale nonce received from 'Room 127'

This happens just as the extension loses registration, so I'm assuming this is the reason for the failure.

Some Google searches recommend setting "pedantic=no" and "qualify=no", but I'm not exactly sure where to do that. I tried to find those on the Phones tab for the tenant and they're not in the list (screenshot attached). Do they need to be added somewhere?

Have any of you encountered this issue and if so, can you offer some insight? Thanks.

telligent
telligent's picture
Joined: 2017/11/16
Points: 0

I found the qualify option under the Phones tab and set it to "no", but the issue still persists.

volodya
volodya's picture
Joined: 2017/01/05
Points: 260

Best way to find the problem is to capture SIP traffic. Sharing it would help a lot.

Mentioned settings are located on Phone tab of User Extension configuration window. But I would assume that if devices become unreachable because of remote firewall, setting qualify to no will not help.

Also you should make sure SIP ALG feature on remote router is disabled if it's present.

telligent
telligent's picture
Joined: 2017/11/16
Points: 0

I'll pull a pcap and post shortly.

The devices are behind a remote firewall but this issue is only affecting 2 to 3 of the 80 extensions on the network at any given time. All extensions are configured on ATAs, so other extensions with the same network settings are not affected. Outbound from the network isn't restricted. It was my understanding that a combination of "nat=yes" in asterisk and "nat=keep-alive" from the device would eliminate any problems from inbound firewall rules (and this works for all other extensions).

I've tested the pedantic and qualify options, but the problem persists. I've confirmed SIP ALG is off.