5 posts / 0 new
Last post
telligent
telligent's picture
Joined: 2017/11/16
Points: 0

I logged in to the web gui this morning and ran a webmin/module update. Once that I finished, I attempted to log in to the Thirdlane interface and saw this error message:


The Server returned the error status code = -1
Database version (163) does not match database version (168) required by the application. Please check /etc/webmin/asterisk/install.log for any errors during software update

I checked the install.log file and found these entries:


Wed Apr 11 12:41:03 2018 Existing database version 163, current application database version 168 - database changes required

Wed Apr 11 12:41:03 2018 Log database version 26 is current - no database changes required

Wed Apr 11 12:41:03 2018 Performing database backup

Wed Apr 11 12:41:03 2018 Database backup stored in /etc/webmin/asterisk/pbxconf-163-20180411-124101.gz

Wed Apr 11 12:41:03 2018 Trying to update database from version 163 to version 164

Wed Apr 11 12:41:03 2018

Wed Apr 11 12:41:03 2018

Wed Apr 11 12:41:03 2018 alter table tenants DROP FOREIGN KEY tenants_ibfk_1;

Wed Apr 11 12:41:03 2018 alter table tenants DROP FOREIGN KEY tenants_ibfk_2;

Wed Apr 11 12:41:03 2018

Wed Apr 11 12:41:03 2018 ALTER TABLE `tenants` change column `primary_locationid` `primary_groupid` int(11) NOT NULL default '1';

Wed Apr 11 12:41:03 2018 ALTER TABLE `tenants` change column `secondary_locationid` `secondary_groupid` int(11) NOT NULL default '1';

Wed Apr 11 12:41:03 2018

Wed Apr 11 12:41:03 2018 alter table tenants ADD FOREIGN KEY (primary_groupid) REFERENCES server_groups(id) ON DELETE RESTRICT;

Wed Apr 11 12:41:03 2018 alter table tenants ADD FOREIGN KEY (secondary_groupid) REFERENCES server_groups(id) ON DELETE RESTRICT;

Wed Apr 11 12:41:03 2018

Wed Apr 11 12:41:03 2018

Wed Apr 11 12:41:03 2018

Wed Apr 11 12:41:03 2018 Error executing sql. ERROR 1025 (HY000) at line 2: Error on rename of './pbxconf/tenants' to './pbxconf/#sql2-6ce-5994' (errno: 152)

Wed Apr 11 12:41:03 2018

Wed Apr 11 12:41:03 2018 Error occured when executing /usr/libexec/webmin/asterisk/patches/mysql/patch_db_164.pl

Wed Apr 11 12:41:03 2018 Database is now at version 163. Failed to update database to current version 168

Is there anything I can do on the server to rectify this issue?

mattdarnell
mattdarnell's picture
Joined: 2007/10/25
Points: 20

I have read that you are not supposed to upgrade webmin, only yum clean all & yum update.

Not sure if you can downgrade webmin.

The ISO should include some kind of webmin flag to disallow updates.

telligent
telligent's picture
Joined: 2017/11/16
Points: 0

I spoke with Alex at Thirdlane yesterday afternoon and he let me know that as well. I went ahead and restored a backup image of the PBX, but the error is still there. I'm wondering if it was present before I ran the webmin update.

volodya
volodya's picture
Joined: 2017/01/05
Points: 220

Hi,

My name is Volodya. I work for Thirdlane. Please send me access information to your server on volodya@thirdlane.com so I could look into your problem.

telligent
telligent's picture
Joined: 2017/11/16
Points: 0

Hi Volodya. Thank you for your help. I've sent the server details to you via encrypted email. Please let me know if you do not receive them.