7 posts / 0 new
Last post
samslack
samslack's picture
Joined: 2017/08/15
Points: 0

We are running trail we can get incoming calls to come in but outbound just gives us busy signal.

Icreated a outbound call route called Long distance

_1NXXNXXXXXX

have it set to unrestricted

associated script is tI-dialout-1-trunk | Dial Out (1 trunk)

How long to ring is at 60

the trunk is Sip/VoIP_inno_out1

Am I missing something?

under general settings >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

for the trunk I have (tI-dialout trunk)

Type is set to friend

context is set to from-outside

Call limit is no limit

for Dial out options>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Dialsrting creation is generate

number of digits to strip is 0 everything else is blank

I am attaching screenshots. This system is new to me

samslack
samslack's picture
Joined: 2017/08/15
Points: 0

Pictures added

Attached file: 

eeman
eeman's picture
Joined: 2007/11/06
Points: 290

this mostly looks correct. correct enough to work anyway. Technically voip innovations wants different entries for inbound vs outbound. insecure=port.invite applies to inbound traffic. Type should always be peer (outbound) for any connection using IP method of authentication (no proxy auth) for both inbound/outbound (hence why outbound is bad description of a value that really means peer).

you will need to watch your asterisk CLI to see if the carrier gets called and if they reject the call.

with VI, there are only specific IP they let you send to. This might not be one of them.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

eeman
eeman's picture
Joined: 2007/11/06
Points: 290

also they do not support alaw (g711a) as that is Europe ONLY

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

thirdlane
thirdlane's picture
Joined: 2007/02/07
Points: 530

When Asterisk server is behind NAT firewall, in order for Asterisk to use public (so that the trunk provider would not reject the call authenticated by ip ) the externip has to be specified in the general section of sip.conf

externip=external ip address

another parameter that is generally required to treat local addresses without NAT in cases like this is

localnet = net.ip.addr/subnet.mask

Alex Epshteyn
Third Lane Technologies
Multi Tenant Asterisk PBX

eeman
eeman's picture
Joined: 2007/11/06
Points: 290

Do not do that... You still get a lot of one-way audio. NEVER run asterisk from NAT. Use a real IP. The firewall already installed on your PBX is the _exact_ same software running on 95% of all commercial firewalls on the market. With the exception of BSD based firewalls running pf (which have huge problems with SIP) the overwhelming majority use IPTables for their filtering and statefull inspections.

Erik Smith
dCAP
Thirdlane/Asterisk Support available
esmith.bgnv@gmail.com

thirdlane
thirdlane's picture
Joined: 2007/02/07
Points: 530

Erik, i understand your point. Some customers insist on having PBX behind a firewall, so my comment was about settings for that case.

Alex Epshteyn
Third Lane Technologies
Multi Tenant Asterisk PBX