7 posts / 0 new
Last post
aponnath
aponnath's picture
Joined: 2014/02/26
Points: 0

Is there a document or script which fixes the issue with yum update ? As of end of November 2020 CentOS is no longer supported and any call of yum update will fail. Its a bit strange that there is no info on that in any forum here or that there was no migration to CentOs 7 which is a supported version. I found a few hacks online but as Thirdlane is to picky as far as what can be changed without breaking more i dont want to go that route.

[root@thirdlane10 ~]# yum update
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. Invalid release/repo/arch combination/
removing mirrorlist with no valid mirrors: /var/cache/yum/x86_64/6/base/mirrorlist.txt
Error: Cannot find a valid baseurl for repo: base
[root@thirdlane10 ~]#

[root@thirdlane10 ~]# tl-update

Adjusting Nginx configuration
Stopping nginx: [ OK ]
Starting nginx: [ OK ]
Stopping nginx: [ OK ]
Starting nginx: [ OK ]

Updating java-1.8.0-openjdk-headless.x86_64
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
YumRepo Error: All mirror URLs are not using ftp, http[s] or file.
Eg. Invalid release/repo/arch combination/
removing mirrorlist with no valid mirrors: /var/cache/yum/x86_64/6/base/mirrorlist.txt
Error: Cannot find a valid baseurl for repo: base

System adjustment completed
[root@thirdlane10 ~]#

aponnath
aponnath's picture
Joined: 2014/02/26
Points: 0

Just as an FYI this is the same error i get when running on a 9.x which i try to update or the latest image

thirdlane
thirdlane's picture
Joined: 2007/02/07
Points: 520

We will provide the instructions and a script for dealing with the repos shortly. Unfortunately there are more issues with CentOS which we are monitoring.

Alex Epshteyn
Third Lane Technologies
Multi Tenant Asterisk PBX

aponnath
aponnath's picture
Joined: 2014/02/26
Points: 0

Quit interesting as without a fix you currently cant upgrade or even use the new image as you cant get any provisioning templates.

I used the below update in the CentOS-Base.repo file and that allows you to do yum update but it seems to break other stuff specially as far as the gui goes. When provisioning a Extension it pretty much fails after yo u created one. If you lucky to open another one it will not save changes or when you want to go from one tab to other the tabs are empty. Tried Chrome, IE and Firefox and all behave the same. A reboot will fix it which honestly is not an acceptable solution. So this CentOS is a major issue and one would expect that the writting of Endof Life was on the wall

=================== Revised version of repo file=====================
[base]
name=CentOS-$releasever - Base
# mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os&infra=$infra
# baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
baseurl=https://vault.centos.org/6.10/os/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

# released updates
[updates]
name=CentOS-$releasever - Updates
# mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates&infra=$infra
# baseurl=http://mirror.centos.org/centos/$releasever/updates/$basearch/
baseurl=https://vault.centos.org/6.10/updates/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

# additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras
# mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras&infra=$infra
# baseurl=http://mirror.centos.org/centos/$releasever/extras/$basearch/
baseurl=https://vault.centos.org/6.10/extras/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6

aponnath
aponnath's picture
Joined: 2014/02/26
Points: 0

Is this still a supported product or has it reached its end. One has to think if the underlaying OS in this case CentOS 6 reached end of life, Thirdlane would publicly either provide a temp work around or move to a supported platform like CentOS8 etc. But other then silence nothing happened....

volodya
volodya's picture
Joined: 2017/01/05
Points: 280

Hello,

You need to run the following command to adjust the default repository:
curl -o fix-repo.sh http://lib.thirdlane.com/download/getpbx-el6/fix-repo.sh && sudo bash fix-repo.sh

aponnath
aponnath's picture
Joined: 2014/02/26
Points: 0

Thanks, but shouldn't this be a major bulletin as without it you cant install current version ?