This post is at: ForumGeneral Questions
9 posts / 0 new
Last post
mcampbell@1poin...
mcampbell@1pointcom.com's picture
Joined: 2015/05/20
Points: 0

I am unable to sign in to TL Connect Android.

I always receive the following message: "Connection Error - Connection failed. Check your server name, internet connection and try again. Also make sure that your server uses a valid SSL certificate"

I have no issue logging in to Connect using Chrome on the same device. My SSL certificate is fine.

I have tried multiple variants of the server name to no avail (i.e. www.servername.com,
www.servername.com/connect, https://www.servername.com, https://www.servername.com/connect)

I have attempted this on my local network, on the cellular network, and another individual in the organization has tried TL Connect app on his Android with the same result.

I am running TL-MTE 8.3.1.1 and Android TL Connect 1.4.1

I have attached a screenshot of the message (note server address, username and password have been removed for obvious reasons.)

mcampbell@1poin...
mcampbell@1pointcom.com's picture
Joined: 2015/05/20
Points: 0

Here is the screenshot - hopefully it show on this post.

Attached file: 

volodya
volodya's picture
Joined: 2017/01/05
Points: 70

Hello,

Can you please clarify who is CA of your certificate? Most likely adding intermediate certificate if you didn't already will fix problem fort Android Connect client.

mcampbell@1poin...
mcampbell@1pointcom.com's picture
Joined: 2015/05/20
Points: 0

Hi,

CA is GoDaddy. I know I personally concatenated the intermediate cert with the other certs so it's there on my site. Connect works fine on my Android's Chrome browser. I'll try the connect app on MS & Linux to see what kind of luck I have there.

Thanks.

mcampbell@1poin...
mcampbell@1pointcom.com's picture
Joined: 2015/05/20
Points: 0

FYI I am able to use Linux version of Connect with no issue whatsoever.

volodya
volodya's picture
Joined: 2017/01/05
Points: 70

Have you tried using Certificate Chain Upload option specifically?

mcampbell@1poin...
mcampbell@1pointcom.com's picture
Joined: 2015/05/20
Points: 0

I have not tried that...can you provide any guidance?

Thanks.

mcampbell@1poin...
mcampbell@1pointcom.com's picture
Joined: 2015/05/20
Points: 0

I found the option you mention. I will see if I can get any further with this.

Thanks for the information.

mcampbell@1poin...
mcampbell@1pointcom.com's picture
Joined: 2015/05/20
Points: 0

Ah, that worked like a charm - I was able to painlessly add the GD intermediate certificate.

When I mentioned that I had concatenated that before it was for some older V7 and V2 servers we have in use. I forgot I never did that for this V8 server and its GUI implementation of the certificate.

Thanks volodya for your insight!