5 posts / 0 new
Last post
eherr
eherr's picture
Joined: 2011/11/11
Points: 0

Hi All -

I am in the process of manually migrating my ancient thirdlane server to the newest release.

I have had a call on hold for about 20-25 minutes and then the call suddenly dropped. It is a Polycom phone that I use all the time on my production system so I highly doubt it has anything to do with the endpoint side.

It looks like the call cleared out gracefully
[2020-09-27 11:35:49] VERBOSE[20902][C-00000000] bridge_channel.c: Channel SIP/Bandwidth_1-00000000 left 'simple_bridge' basic-bridge
[2020-09-27 11:35:49] VERBOSE[20906][C-00000000] bridge_channel.c: Channel Local/5555@from-inside-testtenant-00000000;1 left 'simple_bridge' basic-bridge
[2020-09-27 11:35:49] VERBOSE[20902][C-00000000] app_macro.c: Spawn extension (macro-tl-ringgroup-base, dial, 2) exited non-zero on 'SIP/Bandwidth_1-00000000' in macro 'tl-ringgroup-base'
[2020-09-27 11:35:49] VERBOSE[20903][C-00000000] res_musiconhold.c: Stopped music on hold on Local/5555@from-inside-testtenant-00000000;2
[2020-09-27 11:35:49] VERBOSE[20902][C-00000000] pbx.c: Spawn extension (Test-ExtensionBased-testtenant, s, 3) exited non-zero on 'SIP/Bandwidth_1-00000000'
[2020-09-27 11:35:49] VERBOSE[20903][C-00000000] bridge_channel.c: Channel Local/5555@from-inside-testtenant-00000000;2 left 'simple_bridge' basic-bridge
[2020-09-27 11:35:49] VERBOSE[20905][C-00000000] bridge_channel.c: Channel SIP/5555-testtenant-00000002 left 'simple_bridge' basic-bridge
[2020-09-27 11:35:49] VERBOSE[20903][C-00000000] app_macro.c: Spawn extension (macro-tl-userexten-rg-base, s, 20) exited non-zero on 'Local/5555@from-inside-testtenant-00000000;2' in macro 'tl-userexten-rg-base'
[2020-09-27 11:35:49] VERBOSE[20903][C-00000000] app_macro.c: Spawn extension (macro-tl-stdexten, s, 14) exited non-zero on 'Local/5555@from-inside-testtenant-00000000;2' in macro 'tl-stdexten'
[2020-09-27 11:35:49] VERBOSE[20903][C-00000000] pbx.c: Spawn extension (from-inside-redir-testtenant, 5555, 1) exited non-zero on 'Local/5555@from-inside-testtenant-00000000;2'
[2020-09-27 11:35:49] VERBOSE[20903][C-00000000] pbx.c: Executing [h@from-inside-redir-testtenant:1] Hangup("Local/5555@from-inside-testtenant-00000000;2", "") in new stack
[2020-09-27 11:35:49] VERBOSE[20903][C-00000000] pbx.c: Spawn extension (from-inside-redir-testtenant, h, 1) exited non-zero on 'Local/5555@from-inside-testtenant-00000000;2'

I did notice with kamcmd ul.dump that the State of the extension/AoR was now showing CS_DIRTY

Once the state went back to CS_SYNC, I could call the extension again.

What do I need to do so the call doesnt drop or is there some setting that needs to be adjusted to prevent the call from dropping?

Thanks!

eherr
eherr's picture
Joined: 2011/11/11
Points: 0

I noticed when I run the kamcmd ul.dump, I see the Keepalive: 0

sip_users in the DB show nat as NO/NULL

eherr
eherr's picture
Joined: 2011/11/11
Points: 0

I ran yum make clean and yum update as stated in the docs.

my call has been connected for 61 minutes now and continuing.

However, I can no longer get into the web portal.

Failed to determine Webmin root from SERVER_ROOT, SCRIPT_FILENAME or the full command line

volodya
volodya's picture
Joined: 2017/01/05
Points: 260

Hello,

The call can be dropped by a number of reasons. It would be helpful to look at the SIP packet capture of such a call.

You can look at the rtpholdtimeout setting in the /etc/asterisk/sip.conf configuration file if this happens to the calls on hold.

Please try to restart the Webmin service to resolve the problem with accessing the GUI.

eherr
eherr's picture
Joined: 2011/11/11
Points: 0

I have a few sngrep outputs saved. I am not entirely sure if it was the installation and lack of running yum update or the SIP Provider. Since I ran yum update, I am no longer getting the hangup around that time slice. Testing has not been able to reproduce the issue since then so I am just 'monitoring' it for now.