This post is at: ForumGeneral questions
By Skydoc

Hi All,

A quick question about analog Digium Boards, Zap and DID that I was hoping for help debugging.

We have an analog Digium AEX800 with two TXS and four FXO (See output of ztcfg below)

# /sbin/ztcfg -vvv

Zaptel Version: SVN-branch-1.4-r4609
Echo Canceller: MG2
Configuration
======================
Channel map:
Channel 01: FXS Kewlstart (Default) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Slaves: 02)
Channel 05: FXO Kewlstart (Default) (Slaves: 05)
Channel 06: FXO Kewlstart (Default) (Slaves: 06)
Channel 07: FXO Kewlstart (Default) (Slaves: 07)
Channel 08: FXO Kewlstart (Default) (Slaves: 08)

Calls are incoming to Channel 01 and 02 from the UK POTS PSTN and are appropriately received, with good quality audio, call handling and Caller ID detection.

The problem is that I dont seem to be able to create a workable Channel to DID map.

Here's what I did -

Set up and tested the Zap Channels.

Created a Zap Trunk called simply 1 and made sure it was enabled.

Created a Channel to DID map where I selected Channel 1 and allocated a number 019XXXXXXX

Created an inbound route for this DID - 019XXXXXXX and pointed it at an internal extension to test.

Called the Incoming BT line to test -

Result - all works fine except the routing based on the DID that I created above - which resolutely fails to work - all the calls on both incoming lines to the AEX800 end up being handled by s.

My config files are pretty basic:


zapata.conf:

[channels]
; hardware channels defaults - these populate downwards unless overridden

; now we define the extension channels on ports 5 -8 FXS devices with FXO signalling

context=from-inside
signalling=fxo_ks
language=en
channel => 5

context=from-inside
signalling=fxo_ks
language=en
channel => 6

context=from-inside
signalling=fxo_ks
language=en
channel => 7

context=from-inside
signalling=fxo_ks
language=en
channel => 8

; and define the incoming channel attached to port 1 - 2

; and now define some of the parameters for the incoming analog OTS / PSTN line thus

usecallerid=yes
cidsignalling=v23 ; Added for UK CLI detection
cidstart=polarity ; Added for UK CLI detection
hidecallerid=no
callwaiting=no
threewaycalling=yes
transfer=yes
echocancel=yes
echotraining=yes
immediate=no

;set up a group for both the following lines
group=1
; (dont really need to define options more than once as they cascade)

context=from-outside
signalling=fxs_ks
callerid=asreceived
language=en
channel => 1

; and define the second incoming channel

context=from-outside
signalling=fxs_ks
callerid=asreceived
language=en
channel => 2

The Zap Channel part of trunks.include

TRUNK_NAME_1=1
TRUNK_PROTOCOL_1=ZAP
TRUNK_DESCRIPTION_1=
TRUNK_DIRECTION_1=both
TRUNK_PROVIDER_URL_1=
TRUNK_STATUS_1=1
TRUNK_STRIP_1=0
TRUNK_PREPEND_1=
TRUNK_CLI_STRIP_1=0
TRUNK_CLI_PREPEND_1=
TRUNK_DIALSTRING_1=

and Zap.conf

[1]
qualify=no
nat=no
context=from-outside
type=friend

and lastly (and backwards in order somewhat!) - Zaptel.conf

defaultzone=uk
loadzone=uk
fxsks=1,2
fxoks=5,6,7,8

Can anyone see where I have gone wrong? I would have thought that this would work fine - or am I missing a script error somewhere?

Any help would be very appreciated as this card is almost perfect now!

Kind Regards and thanks in advance,

Geoff Tothill.

By eeman

yep, you forgot to tell the 's' handler to run the script that uses your channel-to-did map =)

Erik Smith
CTO
BluegrassNet Voice
dCAP
Thirdlane/Asterisk Support available
eeman @ bluegrassnetvoice.com

By Skydoc

Erik,

You really know your way around this stuff!

Thanks so much for this pointer - you were quite right - I wasn't using the right script - as soon as I selected 'Reroute Analog Lines' for my s route it all worked perfectly!

Your help, as ever, has been very much appreciated and has saved me hours of toil!

Have a great weekend,

Kind Regards,

Geoff.